Feature doesn't activate in site collection

Dec 10, 2015 at 9:17 PM
Edited Dec 10, 2015 at 9:51 PM

I'm using latest release V1.2.10 with SharePoint 2013 Enterprise

I'm able to deploy solutions successfully, but the features do not activate. I have tried this with multiple SharePoint solutions and always see the same behavior. The features activate fine if I go into site settings and activate manually. I am sure I have the correct feature IDs.

As a test I went back to the release version setup2013.exe.config file and changed only the SolutionID, FarmFeatureID, FeatureID, and SolutionFile and I see the same behavior.
The DemoSolution.wsp solution doesn't deploy properly which is why I don't use that as an example.
I've tried using only FeatureID as FarmFeatureID is supposedly obsolete. No change.

Thoughts? What could be causing this?

I have FeatureScope set to Site, which is correct.
I am a site collection administrator.
I tried a second farm - same problem.
I tried 1.2.8 - same problem.
Feb 3, 2016 at 9:16 PM
What do you mean "the features do not activate" ?

(Note: It is not supposed to automatically activate site collection features across all site collections across all web applications of an entire farm.)