Issue deploying my solution.

Nov 30, 2007 at 9:08 PM
Edited Nov 30, 2007 at 9:30 PM
I'm working on deploying a solution I've created using the Setup.exe program.

Currently the installation fails with the messge: "Object reference not set to an instance of an object."

It then rolls back the installation (however the solution is still installed in SharePoint), and the next screen gives me the following information:

"***** ERROR *****
Object reference not set to an instance of an object.
System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.InstallProcessControl.CreateDeploymentJobCommand.Execute()
at CodePlex.SharePointInstaller.InstallProcessControl.TimerEventInstall(Object myObject, EventArgs myEventArgs)
Any pointers on where to start looking for whats going wrong would be appreciated.

Dec 3, 2007 at 11:38 PM
Well I did some more digging. It seems that a bug had been introduced into the code base prior to me attempting to integrate the Solution Installer. Once I fixed the bug the installer worked as advertised.

I had presumed the error was in my code-base all along, it is unfortunate the error messages weren't more clear as to where the error was occurring.

Mar 18, 2008 at 3:30 PM
Dear Chris,

Could you please give me some information about the thngs that you changes in you code base?

I'm receiving exactly the same error when using SharePoint Solution Installer.
The solutions get installed though, I receive the errors when implementing the solution to the webapp.

When i try to implement from the central administration tool, everything goes okay.