1

Closed

Error on Deactivating feature(s) on site collection(s)

description

Hi,


I am getting below error while repair SharePoint 2013 solution installer v 1.2.8

Info: Deactivating 5 total activations of 2 feature(s) on 5 location(s).
Info: Deactivating 1 feature(s) on 1 site collection(s).
*Error: Deactivating 1 feature(s) on 1 site collection(s). feature:
Exception: System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.FeatureActivator.DoSiteActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformAllActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformActivations(ActivationDirection direction, InstallOperation operation, ILog log)
*Error: Error: Deactivate
Exception: System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.FeatureActivator.DoSiteActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformAllActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformActivations(ActivationDirection direction, InstallOperation operation, ILog log)
Info: No feature de/activations completed, so none to rollback
Info: ***** SOLUTION RETRACTION *****

Info: ***** SOLUTION DEPLOYMENT *****
Info: Installing solution at level 15: .wsp
Info: solution ContainsWebApplicationResource: True, applications: 1
Info: Deploying to web application(s): Portal.
Info: The solution was successfully deployed.
The solution was successfully deployed.

Info: Activating 5 total activations of 2 feature(s) on 5 location(s).
Info: Activating feature(s) on 1 site collection(s).
*Error: Activating feature(s) on 1 site collection(s). feature:
Exception: System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.FeatureActivator.DoSiteActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformAllActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformActivations(ActivationDirection direction, InstallOperation operation, ILog log)
*Error: Error: Activate
Exception: System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.FeatureActivator.DoSiteActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformAllActivations()
at CodePlex.SharePointInstaller.FeatureActivator.PerformActivations(ActivationDirection direction, InstallOperation operation, ILog log)
Info: No feature de/activations completed, so none to rollback


Any suggestion , what i have to do in such situation?

Thanks in advance.
Regards,
Closed Feb 18, 2016 at 4:59 PM by PerrySharePoint
Very old report and apparently fixed since

comments

PerrySharePoint wrote Feb 3, 2016 at 8:19 PM

I think 1.2.10 may have addressed some null pointer issue?

(I have a fix for another one, but it manifests more clearly, and I cannot upload the fix because the codeplex svn bridge is not working very well--apparently this has been a problem for months).

PerrySharePoint wrote Feb 18, 2016 at 4:57 PM

I think this was fixed in a later release.

wrote Feb 18, 2016 at 4:58 PM

wrote Feb 18, 2016 at 4:59 PM