Instructions on Using SharePoint Solution Installer

Mar 6, 2008 at 3:55 PM
Hi,

I new to using the SharePoint Solution installer utility. Here is what i have done to try to get the setup.exe to install my solution.

I modified the Setup.exe.config with the apporiate the information...
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="BannerImage" value="Default"/>
<add key="LogoImage" value="None"/>
<add key="EULA" value="EULA.rtf"/>
<add key="SolutionId" value="641DA9DB-A4D6-411e-BCE8-5CF4B04D03A0"/> <!-- Generated a new GUID using the New GUID Utility in VS 2008 -->
<add key="FarmFeatureId" value="F08ED06E-9B00-400b-8243-63A210A5D0B8"/> <!-- Generated a new GUID using the New GUID Utility VS 2008-->
<add key="SolutionFile" value="CustomLinkListWebPart.wsp"/> <!-- Made a reference to the my WSP file -->
<add key="SolutionTitle" value="CustomLinkListWebPart Solution"/>
<add key="SolutionVersion" value="1.0.0.0"/>
<add key="UpgradeDescription" value="Upgrades {SolutionTitle} on all frontend web servers in the SharePoint farm."/>
<add key="RequireDeploymentToCentralAdminWebApplication" value="true"/>
<add key="RequireDeploymentToAllContentWebApplications" value="false"/>
</appSettings>
</configuration>

Once i run the installer...it verifies my environment and approves the process to move forward with the installation. Once installing the package i get a...
          • ERROR *****
Object reference not set to an instance of an object.
System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.InstallProcessControl.CreateDeploymentJobCommand.Execute()
at CodePlex.SharePointInstaller.InstallProcessControl.TimerEventInstall(Object myObject, EventArgs myEventArgs)


This could be related to my lack of knowlege of using this installer or maybe this a new issues.

Could someone please point me the right direction.

Thank you,
-Wayne