Deployment problem to Share point server.

Feb 11, 2008 at 1:08 PM
Hi,

When I'm going to deploy the .wsp file using setup.exe, its is stucking on some point. The message is
"Waiting (max 15 minutes) for solution retraction job to complete. Press abort to stop."...

after sometimes its saying "time out error"... so i can't deploy my solution to share point site.

Can anyone please help me to overcome this problem.

Thank you,
Regards.
-Susantha-
Feb 12, 2008 at 8:59 PM
You might want to try the manual approach without using the installer and see if SharePoint will give you more details.

To do the manual approach you will need to run stsadm (in the 12 hive\bin) with the "-o addsolution" option (try "stsadm -help addsolution" for more details). Then go to SharePoint 3.0 Central Administration -> Operations -> Solution Management. Then select your WSP and try to deploy it from that screen. I'd be interested in knowing what you find.

Kirk


susantha wrote:
Hi,

When I'm going to deploy the .wsp file using setup.exe, its is stucking on some point. The message is
"Waiting (max 15 minutes) for solution retraction job to complete. Press abort to stop."...

after sometimes its saying "time out error"... so i can't deploy my solution to share point site.

Can anyone please help me to overcome this problem.

Thank you,
Regards.
-Susantha-

Feb 14, 2008 at 3:59 PM
Yes sir, thank you very much for instant reply. Sorry for belated response.. I tried it out as you said..its really worked.
Now i totally forgot about .exe installation.. because im doing it manually by command prompt. I learned lot.. :-)

Another problem, may i ask.
I deployed my aspx pages to sharepoint content. But after I redesigned the master page in sharepoint server using sharepoint designer, that worked content page, doesn't work.. Is there any issue with , after edit the master page ..?
I edited existing master page..(default.master)

Thanks in advance.